Announcement

As of April 17, 2018, this site is now in read-only mode. To start new Blackbaud Developer’s discussions, you will find Developer Discussions in the Blackbaud CRM Community.

To post or respond to Blackbaud Community discussions, you will have to login using a www.blackbaud.com login. Learn how to login here. If you have questions or need assistance, please email community@blackbaud.com.

1.7k questions

3.2k answers

401 users

Categories

1.7k questions

3.2k answers

401 users

Hi All,

I have an existing model UI project. I need to modify the html file to display a new field. I modified the dataform that the UI is based off and verified that the linked spec showed the change. I then modified the html file to include the new field. The problem is the new field doesn't show up. Any suggestions? I even decided to copy the html file and add the number 2 to the end just to make sure its using the new html file.

Thanks!

asked by webtechie (465 points)

1 Answer

 
Best answer

I modified the CodeGen code. I manually added the lines for the new field and it works

answered by webtechie (465 points)
You should not have to manually edit the CodeGen code.  With the applicable spec or UIModel selected just use the 'Refresh UI Model' option from the tools menu in Visual Studio and the CodeGen code gets updated for the changes to the spec.
I had the same problem and did the same. Don't know why does not the UI Model refresh on its own when the meta data of the report is changed.
It does refresh though if you change the guid of the report spec.
...